CUDA and OptiX Error Troubleshooting
This Article will explore some possible troubleshooting steps for CUDA and Optix Error
OptiX Error 7990:
[Brief summary of the customer's issue they had experienced.]
[C] Optix error: 7990 (Internal error)
Device : NVIDIA GPU NAME
[C] Failed initializing OptiX driver
Environment Details
- KeyShot | Network Rendering | KeyShot Viewer
Cause
- OptiX Error 7990: Failed to initialize Optix : the error 7900 is the generic OPTIX_ERROR_CUDA_ERROR. It is hard to tell the cause as it could be hardware or software.
Resolution
- Update the driver to at least version 545.84
- Please set KeyShot to High Performance in the Graphics settings (see below)
- If Network Rendering is affected, set the KeyShot Network Worker Try to High Performance as well, located by default in C:\Program Files\KeyShot Network Rendering\bin
Set preferred GPU setting on Windows:
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Press the Windows + I shortcut to open the Settings app and click on Display.
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Under display settings, scroll down and click Graphics.
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Click on the Browse button and select the following depending on how KeyShot was installed
Installed just for Me%localappdata%\KeyShot\bin\keyshot.exe
Installed for everyone using this computerC:\Program Files\KeyShot\bin\keyshot.exe
Please use the appropriate version. KeyShot 2023 would have a folder name KeyShot12\bin\keyshot.exe.
KeyShot 2024 and every version after that will be just KeyShot
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Click on the Options button and select "High Performance" from the Graphics specifications drop-down menu.
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Click on the Save button to apply the changes.
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Restart KeyShot
How to create a DxDiag log - Windows
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Press the Windows Key + R.
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Enter "DxDiag" and run the command.
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Press 'Save all information' and save the file in an easy-to-find location.
Additional Resources
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